• Welcome back Guest!

    MARSH is a private reefing group. Comments and suggestions are encouraged, but please keep them positive and constructive. Negative threads, posts, or attacks will be removed from view and reviewed by the staff. Continually disruptive, argumentative, or flagrant rule breakers may be suspended or banned.
  • Hello Guest,

    How would you like to get a Build Thread Contributor title/badge?
    Go here for instuctions.

Neptune cor 20 low voltage

Ecamden

Supporting Member
Joined
Mar 25, 2019
Messages
98
Reaction score
152
Location
Magnolia tx 77354
My Cor 20 is showing low voltage after shutting off for a water change. I shut it off through apex fusion so it wasn't a user error like unplugging it, shut it off the same way I do every time. Went to turn my pumps back on after water change and I'm getting low voltage and the return pump isn't working. I checked the Neptune forum with no luck. Anyone here have any ideas on what to do? Also, Neptune support isn't open on a weekend
 

gregg

President
Administrator
Moderator
Board Member
MARSH Secret Santa 2020
Build Thread Contributor
Joined
Jan 28, 2015
Messages
5,522
Reaction score
2,690
Location
Downtown
Id try plugging it in directly to the power bar or maybe taking it apart and cleaning it, something could have got wedged in there while it was off.
 
OP
Ecamden

Ecamden

Supporting Member
Joined
Mar 25, 2019
Messages
98
Reaction score
152
Location
Magnolia tx 77354
Already tried. I'm pretty sure the driver is bad. So far I haven't been impressed with Neptune pumps or power heads. The wav are awful
 

gregg

President
Administrator
Moderator
Board Member
MARSH Secret Santa 2020
Build Thread Contributor
Joined
Jan 28, 2015
Messages
5,522
Reaction score
2,690
Location
Downtown
i havent tried the power heads but my cor 20 hasnt given me an issue.. the trident should be out in the next couple weeks so im excited about that!
 
OP
Ecamden

Ecamden

Supporting Member
Joined
Mar 25, 2019
Messages
98
Reaction score
152
Location
Magnolia tx 77354
This is my second problem with the cor (wav caused first issue)but after going through 2 returns with the wav in the first month I gave up on them. The first set per Neptune were defective and dried my whole apex. The replacement set just stopped working after a few weeks. Don't get me wrong I love my apex though. Just for over 300 bucks for a pump I expect it to last longer than it has
 

Luman01

Supporting Member
Build Thread Contributor
Joined
Mar 25, 2017
Messages
1,080
Reaction score
325
Location
Richmond
just tell your dad i said he needs to buy you an apex and be done with it!
I’ve been telling him that for a while now! Still nothing! And he complains when we are in Colombia 3000 miles from home wondering if his tank is doing ok. I tell him simple solution APEX! lol I’m really banking on winning the one at rc. He is gonna stay for the raffles while I’m at prom.
 

GotFrogs

Supporting Member
Joined
Feb 23, 2004
Messages
1,054
Reaction score
126
Location
Dickinson
These power supplies they provide with the COR-20 are junk. I just had my second one go out on me for no reason. I am very thankful I have two return pumps and an extra COR-20 on hand that I could steal the power supply from.
 
Top